NO AM SIGNAL

Moderators: JimMann, aaj, mike020150

lovejags
Posts: 33
Joined: Thu Nov 26, 2015 8:07 pm
Location: MALTON YORKSHIRE

NO AM SIGNAL

Postby lovejags » Mon Mar 05, 2018 8:59 pm

I have lost the am signal on my stereo everything else works fine somebody suggested the aerial amplifier could be at fault. Has anyone any ideas also is it situated in the boot or behind the stereo. My car is a 2007 xkr convertible.

mike020150

Member
Posts: 2353
Joined: Wed Feb 08, 2006 6:26 pm

Re: NO AM SIGNAL

Postby mike020150 » Tue Mar 06, 2018 11:26 am

If your car has an external aerial, it won't have an antenna amplifier. If it's a 2008 model year car without an antenna, it will have an amplifier and it will have a hardwire connection to the amplifier in the boot. The amplifier is connected to the integrated audio module, via the FM antenna signal splitter, by a coaxial cable. On convertible models, a block connected to the amplifier provides the earth connection through the body. Mike.
2014 XK Dynamic R convertible; 1977 Daimler Double Six Coupe; XE S

lovejags
Posts: 33
Joined: Thu Nov 26, 2015 8:07 pm
Location: MALTON YORKSHIRE

Re: NO AM SIGNAL

Postby lovejags » Sat Jun 02, 2018 2:30 pm

Hi Mike know it's been a while you say there is no amplifier but I have found one on ebay item no.202075990152. I have looked behind the o/s rear light cluster and the same box is there with 4 connectors .Could you have a look and see if it is.P.S it is an external aerial.

mike020150

Member
Posts: 2353
Joined: Wed Feb 08, 2006 6:26 pm

Re: NO AM SIGNAL

Postby mike020150 » Wed Jun 06, 2018 4:55 pm

I suspect you are looking at the AM/FM signal splitter located near the OSR lamp unit. Mike.
2014 XK Dynamic R convertible; 1977 Daimler Double Six Coupe; XE S

lovejags
Posts: 33
Joined: Thu Nov 26, 2015 8:07 pm
Location: MALTON YORKSHIRE

Re: NO AM SIGNAL

Postby lovejags » Wed Jun 06, 2018 7:30 pm

Thanks for replying Mike does this unit have any bearing on the reception?

mike020150

Member
Posts: 2353
Joined: Wed Feb 08, 2006 6:26 pm

Re: NO AM SIGNAL

Postby mike020150 » Thu Jun 07, 2018 8:48 am

With such complicated integrated electronics, I'm tempted to say anything is possible but that's a cop out. The splitter is there to split the FM signal between the radio and the sat nav. I don't know whether, if faulty, it could cut out the AM signal. Have you checked all the simple options, like the tightness of connections between the antenna and the audio unit head?
Rather than risk changing component after component in a lengthy search to find the source of the problem, it would be better to have the audio system diagnosed by the full main dealer diagnostics system or its Autologic equivalent. Good Jaguar specialists as well as main dealers should have one or both systems. For the sake of an hour's diagnostic time, a good technician should be able to pinpoint the fault. Then, for minimal cost, you would know whether or not it would be an expensive repair whilst still giving you the opportunity to decide if it would be worth the cost to correct it. Mike.
2014 XK Dynamic R convertible; 1977 Daimler Double Six Coupe; XE S

User avatar
andypryce

Member
Posts: 505
Joined: Sat Apr 24, 2010 12:43 am
Location: Liverpool

Re: NO AM SIGNAL

Postby andypryce » Tue Jun 19, 2018 10:14 pm

Interestingly, I have had the exact same problem on mine since purchase, sadly I have no idea why and have not investigated further, as other more pressing things to do! If you do find a solution please post it back, thanks.
andy

2006 XK


Who is online

Users browsing this forum: No registered users and 2 guests