AC blower fans not working

Moderators: davidr, BigCatXJS, dhdove

User avatar
P.L
Posts: 27
Joined: Tue Jul 12, 2011 1:56 pm
Location: Schorndorf, Germany

AC blower fans not working

Postby P.L » Wed Sep 14, 2011 12:02 pm

Hi there, I was about to work on my not working AC blower fans. The fuses are fine and I can hear the flaps moving when selecting any fan speed or switching to air-circulation. I assume this proves the AC control unit is somehow working?
However, the blower fans do not come up even when set to 'Defrost'. I tried to check the supply for the fan motors but I think I cannot access them with the blower units in place.
Any ideas what to test before removing the blower units? If not, are there any pictures available or advice on how to get them out? I thought I opened all the screws and nuts, pulled the lower flap to release it from the firewall but I cannot make the unit to move...

Thanks,
Peter
1994 XJS AJ16 Coupé Manual

almcl
Posts: 705
Joined: Sun Jan 15, 2006 7:56 pm
Location: Shropshire
Contact:

Re: AC blower fans not working

Postby almcl » Wed Sep 14, 2011 7:15 pm

Once you have the fan box on the bench (two vertical nuts on studs behind a lot of the junk on the sides of the unit have to be released) have a look at the circuit board in the picture below. This may be the cause of the fan problem. There's one in each fan duct and you'll need to drill the rivets out...
Attachments
DSC00469.JPG
Al McL
'93 XJS 4.0 - '05 X type Est 2.0D - '13 XF 2.2D Sportbrake

User avatar
P.L
Posts: 27
Joined: Tue Jul 12, 2011 1:56 pm
Location: Schorndorf, Germany

Re: AC blower fans not working

Postby P.L » Sun Sep 25, 2011 7:59 pm

Job almost done...
Starting on the passenger side revealed the motor's collector totally covered in black dust, most probably from the brushes. I sanded the collector and gave the whole unit a good clean. Surprisingly, the circuit board looked pretty good and is working fine.
Getting the driver side blower out was much easier than the passenger side. However, this time I found the usual diode corroded away beside my already known dusted collector.
Hope to get the electronics fixed soon and the whole thing back in smoothly within the next days.
To be honest, this has been the worst job in my short term of XJS ownership - so far... ;-)
1994 XJS AJ16 Coupé Manual

User avatar
ng4xjs
Posts: 296
Joined: Thu Jul 29, 2010 12:49 pm

Re: AC blower fans not working

Postby ng4xjs » Thu Sep 29, 2011 1:32 pm

Trick is in putting them back. You will need to hold the flap open to make sure it engages/sits properly plus plenty of advice here and elsewhere as to how to reconnect the blue ducting to the units once installed.

Good luck
Nick


Who is online

Users browsing this forum: No registered users and 2 guests