Page 1 of 1

ANTI LOCK LIGHT on X300

Posted: Fri Jan 11, 2019 9:29 am
by bossred
The Anti Lock warning light on my X300 , 3.2 Sport , 1997 , comes on intermittently , on one day not the next!!
Reading the owners manual it almost says Go to JLR , Do not pass Go , do not collect £200 , Frightening.
Could it be a Duff sensor , Bad earth or other connection ? if so where can these be accessed :?:
Thank you in anticipation . Chris

Re: ANTI LOCK LIGHT on X300

Posted: Fri Jan 11, 2019 11:21 am
by steve_m
It could be a dirty wheel sensor.
I've only had mine just over a month and it come on the day after I bought it.
It then came on intermittently for a couple of weeks and the last few days that I drove it the light has stayed off so maybe a bit of use has cleared it up.
It would be worth putting a code reader on it to see what comes up.

Re: ANTI LOCK LIGHT on X300

Posted: Fri Jan 11, 2019 4:27 pm
by DaveNeedham
Take a look at the overvoltage relay..... if it’s the same as the XJ40. From what I can remember it’s located in the boot l/h side the largest on there!
Also check for swarf/dirt on the phonic wheels where the sensors mount.

Dave

Re: ANTI LOCK LIGHT on X300

Posted: Sat Jan 12, 2019 5:51 pm
by andypryce
Agree a sensor most likely culprit, a code reader will tell you. Sensors are available from Eurojag, only a few quid and dead easy to fit.

Re: ANTI LOCK LIGHT on X300

Posted: Sat Jan 12, 2019 6:51 pm
by PeterDavisX300
The ABS warning light is covered on these forums quite extensively. I've gone through plenty of problems with mine, and have explained what the problems could be. The dreaded '1095' problem is the worse, but almost certainly the most common fault now among these older cars. The ecu-unit is a Ford item, and can fairly easily be repaired if you're handy with a soldering iron, and brave! I've done at least Three of these units successfully with the '1095' fault.

Have fun.