ABS Sensors

Moderators: robv12, Popsjag, h18spk

PeterDavisX300

Member
Posts: 230
Joined: Wed Aug 19, 2015 10:17 am

ABS Sensors

Postby PeterDavisX300 » Fri Aug 24, 2018 10:26 am

The ABS warning light has been on for sometime now. I've tried all the usual stuff, braking-hard etc. I disconnected the harness from the pump and did a continuity test from there to all the sensors, all gave a reading of about 1070, so I presumed they're ok. I decided to remove the rear sensors to check them for dirt, and check the reluctor rings. The drivers-side sensor came out very easily. Unfortunately the passenger side sensor popped it's top off leaving the rest of the sensor locked in the hole. This even after soaking the item in release oil for a few days! I don't think the unit is giving the 1095 code, but if it is I can fix that.

So, I have the problem of extracting the rest of the sensor. If anyone has advice on the best way to do this, that would be appreciated?

Also I'll need a replacement sensor, I've put a short wanted in the buy and sell section. If anyone has a sensor for the rear near-side that's known to work, I'd be happy to take it off their hands.

The other question I had was, isn't there a way to fit the later X308 sensors? I can't believe that there is that much difference is there? I can see the wiring is different to the sensor, but what else needs to be changed? They are half the price of the X300 items, I'd be quite happy replacing both rears with new X308 if I knew exactly whats involved.

Lastly, are the front likely to be as naughty to extract as the rears? Any advice or knowledge about all of this would be very welcome.

Peter
1995 X300

Who is online

Users browsing this forum: No registered users and 2 guests